Thread (1 message) 1 message, 1 author, 2024-06-06

Re: [PATCH v2] apply: add unit tests for parse_range

From: Junio C Hamano <hidden>
Date: 2024-06-06 17:24:20

"Philip Peterson via GitGitGadget" [off-list ref] writes:
From: Philip Peterson <redacted>

Also rename parse_range to parse_fragment_range for external linkage.

Signed-off-by: Philip Peterson <redacted>
---
This version saw no reviews (unfortunately).

I just gave another quick glance, did not spot anything glaringly
wrong, and the way the tests are organized as a series of ...
+	TEST(setup_static((struct test_case) {
+		.line = "@@ -4,4",
+		.offset = -1,
+		.expect_suffix = " +",
+		.expect_result = FAILURE,
+		.expect_p1 = 9999,
+		.expect_p2 = 9999
+	}), "negative offset");
... rather pleasant to read.  I'd admit that it does not count as a
proper review, though.

Thanks.


Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help