Re: [PATCH v2 0/5] some chainlint fixes and performance improvements

2 messages, 2 authors, 2023-03-30 · open the first message on its own page

Re: [PATCH v2 0/5] some chainlint fixes and performance improvements

From: Junio C Hamano <hidden>
Date: 2023-03-30 20:32:38

Jeff King [off-list ref] writes:
As before, I think the first patch is the most important, and the rest
are optimizations. But with Eric's patch to chainlint.pl in the middle,
I think the argument for patch 4 (previously patch 3) is much stronger.

Patch 5 remains mostly a cleanup, with no performance improvement. IMHO
the result is easier to follow, but I'm open to arguments to the
contrary.

  [1/5]: tests: run internal chain-linter under "make test"
  [2/5]: tests: replace chainlint subshell with a function
  [3/5]: tests: diagnose unclosed here-doc in chainlint.pl
  [4/5]: tests: drop here-doc check from internal chain-linter
  [5/5]: tests: skip test_eval_ in internal chain-lint
The new step [3/5] makes it easier to justify [4/5], indeed.  Two
primary changes at the beginning are good as before.  The last one
does not make anything particularly easier to read, replacing one
cryptic eval stuff with another, but it does not make it any worse,
and the most importantly, it is clear to see that it does not change
the behaviour.

Will queue.  Thanks.  Let's merge it down to 'next'.

Re: [PATCH v2 0/5] some chainlint fixes and performance improvements

From: Jeff King <hidden>
Date: 2023-03-30 22:09:26

On Thu, Mar 30, 2023 at 01:32:34PM -0700, Junio C Hamano wrote:
quoted
  [5/5]: tests: skip test_eval_ in internal chain-lint
The new step [3/5] makes it easier to justify [4/5], indeed.  Two
primary changes at the beginning are good as before.  The last one
does not make anything particularly easier to read, replacing one
cryptic eval stuff with another, but it does not make it any worse,
and the most importantly, it is clear to see that it does not change
the behaviour.
Yeah, the eval garbage is horrid no matter where it is. The improvement
is that we no longer have to manually save-and-restore the "trace"
variable.
Will queue.  Thanks.  Let's merge it down to 'next'.
Great, thanks. :)

-Peff
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help