Thread (4 messages) 4 messages, 4 authors, 2023-03-30

Re: [PATCH v2 00/17] cocci: remove "the_repository" wrapper macros

From: Elijah Newren <hidden>
Date: 2023-03-30 03:56:46

On Wed, Mar 29, 2023 at 12:02 PM Junio C Hamano [off-list ref] wrote:
Ævar Arnfjörð Bjarmason  [off-list ref] writes:
quoted
 1:  c167bde3c0c !  1:  e1e27490d60 cocci: remove dead rule from "the_repository.pending.cocci"
    @@ Commit message
         cocci: remove dead rule from "the_repository.pending.cocci"

         The "parse_commit_gently" macro went away in [1], so we don't need to
    -    carry his for its migration.
    +    carry this for its migration.

         1. ea3f7e598c8 (revision: use repository from rev_info when parsing
            commits, 2020-06-23)
 2:  1b1fc5d41f5 =  2:  5ac9d5b8905 cocci: fix incorrect & verbose "the_repository" rules
 3:  34c6b8afd6c !  3:  a3fcd19d744 cocci: sort "the_repository" rules by header
    @@ Commit message
         rules. This will make subsequent commits easier to follow, as we'll be
         applying these rules on a header-by-header basis.

    +    Once we've fully applied "the_repository.pending.cocci" we'll keep
    +    this rules around for a while in "the_repository.cocci", to help any
    +    outstanding topics and out-of-tree code to resolve textual or semantic
    +    conflicts with these changes, but eventually we'll remove the
    +    "the_repository.cocci" as a follow-up.
    +
    +    So even if some of these functions are subsequently moved and/or split
    +    into other or new headers there's no risk of this becoming stale, if
    +    and when that happens the we should be removing these rules anyway.
    +
         Signed-off-by: Ævar Arnfjörð Bjarmason [off-list ref]

      ## contrib/coccinelle/the_repository.pending.cocci ##
After removing the rebase noise from later steps, the above two are
the real changes compared to the previous round.

Are people happy with the result?  I think the previous round was
both read carefully on the central piece of the series, with some
spot checks to mechanical parts, and with the above clarification
the series is ready to be merged down to 'next'.

If I am grossly off base in the above assessment, please holler
soonish.  Thanks.
These two changes address the only minor points I had with the series.
My other comments were either being happy about the changes, or noting
some other things outside the scope of this series that would also be
nice to cleanup.  So I'm happy with merging down.
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help