"Victoria Dye via GitGitGadget" [off-list ref] writes:
quoted hunk
+ /*
+ * NEEDSWORK: using 'offsetof()' is cumbersome and should be replaced
+ * with something more akin to 'load_bitmap_entries_v1()'s use of
+ * 'read_be16'/'read_be32'. For consistency with the corresponding
+ * ondisk entry write function ('copy_cache_entry_to_ondisk()'), this
+ * should be done at the same time as removing references to
+ * 'ondisk_cache_entry' there.
+ */
Sounds sensible. Will replace and merge down to 'next'--- it will
most likely be part of the first batch in the next cycle.
Thanks, all.