"John Cai via GitGitGadget" [off-list ref] writes:
From: John Cai <redacted>
When introducing a new flag --batch-command, we will add a flag on the
batch_options struct that indicates whether or not an interactive
command mode will be used that reads commands and arguments off of
stdin.
An intuitive name for this flag would be "command", which can get
confusing with the already existing cmdmode.
Is "command" truly an intuitive name for "were we given '--batch-command'
option?" bit? I dunno.
But I agree that "transform_mode" is much better name than "cmdmode"
for what this member is about.