Re: [PATCH 2/2] docs: add headers in MyFirstObjectWalk
flat view
From: Eric Sunshine <hidden>
Date: 2021-10-27 17:09:33
On Wed, Oct 27, 2021 at 10:05 AM John Cai via GitGitGadget [off-list ref] wrote:
quoted hunk ↗ jump to hunk
In several places, headers need to be included or else the code won't compile. Since this is the first object walk, it would be nice to include them in the tutorial to make it easier to follow. Signed-off-by: John Cai <redacted> ---diff --git a/Documentation/MyFirstObjectWalk.txt b/Documentation/MyFirstObjectWalk.txt@@ -57,9 +57,14 @@ command). So we will send our debug output to `trace_printf()` instead. When Add usage text and `-h` handling, like all subcommands should consistently do -(our test suite will notice and complain if you fail to do so). +(our test suite will notice and complain if you fail to do so). We'll need to include +the "parse-options.h" header.
Makes sense, but we should probably typeset these consistently with backticks rather than double quotes...
quoted hunk ↗ jump to hunk
@@ -195,9 +200,13 @@ Similarly to the default values, we don't have anything to do here yet -Add a new function to `builtin/walken.c`: +Add a new function to `builtin/walken.c`. We'll also need to include the "config.h" header:
... just as `builtin/walken.c` is typeset with backticks (as are other pathnames in this document).
quoted hunk ↗ jump to hunk
@@ -229,8 +238,14 @@ typically done by calling `repo_init_revisions()` with the repository you intend -Add the `struct rev_info` and the `repo_init_revisions()` call: +Add the `struct rev_info` and the `repo_init_revisions()` call. We'll also need to include +the "revision.h" header:
And so on through the remainder of the patch. Thanks.