Re: [PATCH v2 2/5] test-ref-store: tweaks to for-each-reflog-ent format
flat view
From: Ævar Arnfjörð Bjarmason <hidden>
Date: 2021-09-06 22:35:59
On Mon, Sep 06 2021, Han-Wen Nienhuys via GitGitGadget wrote:
quoted hunk ↗ jump to hunk
From: Han-Wen Nienhuys <redacted> Follow the reflog format more closely, so it can be used for comparing reflogs in tests without using inspecting files under .git/logs/ Signed-off-by: Han-Wen Nienhuys <redacted> --- t/helper/test-ref-store.c | 5 ++--- t/t1405-main-ref-store.sh | 1 + 2 files changed, 3 insertions(+), 3 deletions(-)diff --git a/t/helper/test-ref-store.c b/t/helper/test-ref-store.c index b314b81a45b..0fcad9b3812 100644 --- a/t/helper/test-ref-store.c +++ b/t/helper/test-ref-store.c@@ -151,9 +151,8 @@ static int each_reflog(struct object_id *old_oid, struct object_id *new_oid, const char *committer, timestamp_t timestamp, int tz, const char *msg, void *cb_data) { - printf("%s %s %s %"PRItime" %d %s\n", - oid_to_hex(old_oid), oid_to_hex(new_oid), - committer, timestamp, tz, msg); + printf("%s %s %s %" PRItime " %+05d\t%s\n", oid_to_hex(old_oid), + oid_to_hex(new_oid), committer, timestamp, tz, msg);
Nit: Would be a more readable diff if this wasn't a line-wrap-while-at-it change in addition to changing the format string. I.e. the last 4x parameters aren't changed, so leaving them on their own line & just changing the string & the two oid_to_hex()...