Eric Sunshine [off-list ref] writes:
On Tue, Aug 31, 2021 at 10:37 AM Ævar Arnfjörð Bjarmason
[off-list ref] wrote:
quoted
Remove the trailing dot from the warning we emit about gc.log. It's
common for various terminal UX's to allow the user to select "words",
and by including the trailing dot a user wanting to select the path to
gc.log will need to manually remove the trailing dot.
Such a user would also probably need to adjust the path if it e.g. had
spaces in it, but this should address this very common case.
Signed-off-by: Ævar Arnfjörð Bjarmason <redacted>
Suggested-by: Jan Judas <redacted>
---
diff --git a/builtin/gc.c b/builtin/gc.c
@@ -502,7 +502,7 @@ static int report_last_gc_error(void)
warning(_("The last gc run reported the following. "
"Please correct the root cause\n"
- "and remove %s.\n"
+ "and remove %s\n"
Bikeshedding: Adding a colon after "remove" would give this a slightly
more grammatically-correct feel:
Please correct the root cause
and remove: /path/to/repo/.git/gc.log
quoted
"Automatic cleanup will not be performed "
"until the file is removed.\n\n"
"%s"),
OK.
Even more bikeshedding:
Please correct the root cause and remove
/path/to/repo/.git/gc.log
to allow automatic cleanup to resume.
or something.
I also found the line break before "and remove" strange, but I think
that is because the "Please" is not at the beginning of the
paragraph, but is a second sentence. Perhaps unfolding "and remove"
would make the first line overly long?
THanks.
On Tue, Aug 31, 2021 at 2:18 PM Junio C Hamano [off-list ref] wrote:
Eric Sunshine [off-list ref] writes:
quoted
On Tue, Aug 31, 2021 at 10:37 AM Ævar Arnfjörð Bjarmason
[off-list ref] wrote:
quoted
warning(_("The last gc run reported the following. "
"Please correct the root cause\n"
- "and remove %s.\n"
+ "and remove %s\n"
Even more bikeshedding:
Please correct the root cause and remove
/path/to/repo/.git/gc.log
to allow automatic cleanup to resume.
or something.
I also found the line break before "and remove" strange, but I think
that is because the "Please" is not at the beginning of the
paragraph, but is a second sentence. Perhaps unfolding "and remove"
would make the first line overly long?
Yep, you're right, and perhaps my "Even more bikeshedding" didn't
clearly indicate that I was bikeshedding more about combining the
"Please correct..." and "Automatic cleanup..." sentences into a single
sentence, both as a another way to deal with the punctuation issue
(thus allowing easy double-click) and to make the whole thing read a
bit better.
On Tue, Aug 31 2021, Eric Sunshine wrote:
On Tue, Aug 31, 2021 at 2:18 PM Junio C Hamano [off-list ref] wrote:
quoted
Eric Sunshine [off-list ref] writes:
quoted
On Tue, Aug 31, 2021 at 10:37 AM Ævar Arnfjörð Bjarmason
[off-list ref] wrote:
quoted
warning(_("The last gc run reported the following. "
"Please correct the root cause\n"
- "and remove %s.\n"
+ "and remove %s\n"
Even more bikeshedding:
Please correct the root cause and remove
/path/to/repo/.git/gc.log
to allow automatic cleanup to resume.
or something.
I also found the line break before "and remove" strange, but I think
that is because the "Please" is not at the beginning of the
paragraph, but is a second sentence. Perhaps unfolding "and remove"
would make the first line overly long?
Yep, you're right, and perhaps my "Even more bikeshedding" didn't
clearly indicate that I was bikeshedding more about combining the
"Please correct..." and "Automatic cleanup..." sentences into a single
sentence, both as a another way to deal with the punctuation issue
(thus allowing easy double-click) and to make the whole thing read a
bit better.
I'm aware that it's not in any formal style guide, but for what it's
worth I find that something like say:
Eric sent me an E-Mail with the Message-Id
[off-list ref]
My E-Mail client is displaying it right now.
Reads unambiguously as having an implied full-stop after "com>",
especially as the next word starts on its own line, and is capitalized
in a way that it wouldn't be if it weren't the start of a sentence.
In any case, I do think just removing the dot on the basis of that
rationale is an improvement, both for the stated ease of copy/pasting,
and to remove the ambiguity of whether the "." is part of the filename
(yeah *nix filenames can also have \n, but that's a lot less likely).
I don't think sometihng like your "Even more bikeshedding" suggestion is
better, since we're trying to continue a sentence after a potentially
long filename that might on some platforms or OS's contain spaces etc.
In any case, I was hoping to just send a quick fix-as-a-patch to a tiny
UX suggestion, and was hoping to not get into the much more subjective
discussion of how to better reword "git gc"'s error messages in
general. If that's where this thread is headed I'm afraid I'll need to
tap out of it :)
On Tue, Aug 31, 2021 at 4:44 PM Ævar Arnfjörð Bjarmason
[off-list ref] wrote:
In any case, I was hoping to just send a quick fix-as-a-patch to a tiny
UX suggestion, and was hoping to not get into the much more subjective
discussion of how to better reword "git gc"'s error messages in
general. If that's where this thread is headed I'm afraid I'll need to
tap out of it :)
Fair enough. I hope that my explicit mention of "bikeshedding" made it
clear that my comments weren't expectations of change but rather "if
you plan to pursue it further, maybe try these ideas".