René Scharfe [off-list ref] writes:
cf2dc1c238 (speed up alt_odb_usable() with many alternates, 2021-07-07)
introduced the function fspathhash() for calculating path hashes while
respecting the configuration option core.ignorecase. Call it instead of
open-coding it; the resulting code is shorter and less repetitive.
Signed-off-by: René Scharfe <redacted>
---
builtin/sparse-checkout.c | 10 ++--------
dir.c | 13 +++----------
merge-recursive.c | 11 +++--------
3 files changed, 8 insertions(+), 26 deletions(-)
I love this kind of "now we have this thing available, let's use it
at more places" clean-up patch.
Was coccinelle involved in finding these places?
Thanks.