From: ZheNing Hu <redacted>
There are two "if (opt->all_objects)" blocks next
to each other, merge them into one to provide better
readability.
Helped-by: Jeff King [off-list ref]
Signed-off-by: ZheNing Hu <redacted>
Acked-by: Jeff King <redacted>
Signed-off-by: Junio C Hamano <redacted>
---
builtin/cat-file.c | 5 +----
1 file changed, 1 insertion(+), 4 deletions(-)
diff --git a/builtin/cat-file.c b/builtin/cat-file.c
index 02461bb5ea6..243fe6844bc 100644
--- a/builtin/cat-file.c
+++ b/builtin/cat-file.c
@@ -520,14 +520,11 @@ static int batch_objects(struct batch_options *opt)
data.info.typep = &data.type;
if (opt->all_objects) {
+ struct object_cb_data cb;
struct object_info empty = OBJECT_INFO_INIT;
if (!memcmp(&data.info, &empty, sizeof(empty)))
data.skip_object_info = 1;
- }
-
- if (opt->all_objects) {
- struct object_cb_data cb;
if (has_promisor_remote())
warning("This repository uses promisor remotes. Some objects may not be loaded.");--
gitgitgadget