Re: [PATCH v3 0/4] t: new helper test_line_count_cmd
From: Junio C Hamano <hidden>
Date: 2021-06-19 06:17:15
Eric Sunshine [off-list ref] writes:
Since you've dropped the `--out` and `--err` options entirely, I
wonder if now would be a good time to shorten the function name, as
well, in order to further reduce the noise level. Since it now only
tests stdout (and doesn't deal with stderr), a name even shorter than
what I tried for the last version might be even better. So, for
instance, the name test_out_count() might not be too bad:
test_out_count = 0 git ls-files -o &&"Test out" to me sound like trying something out and the part "out" in the name no longer hints it is about "output"; you may have shortened the name too much to be meaningful, I am afraid. Is the helper used to check with anything but equality? Otherwise you can lose "= " to make it shorter. Having said all that, as an external interface, I wonder test_line_count -e = 0 git-ls-files -o would work better. It usually takes <op> <num> <file>, but when $1 is a magic "-e", we shift it out and it becomes <op> <num> <cmd>...