René Scharfe [off-list ref] writes:
The function body can be written like this:
while (fsync(fd) < 0) {
if (errno != EINTR)
die_errno("fsync error on '%s'", msg);
}
I find it easier to read because it has less syntax elements
and is shorter. Bikeshedding, of course. :-/
It indeed is easier to follow. Thanks.