"Jeff Hostetler via GitGitGadget" [off-list ref] writes:
quoted hunk
+struct unix_stream_server_socket {
+int unix_stream_server__create(
+void unix_stream_server__free(
+int unix_stream_server__was_stolen(
I think we reserve __ in our API for names of symbols that normal
callers never have to write (both data like git_attr__true[] and
functions like cmd_bisect__helper()).
It seems that list-objects-filter.h may have introduced the
"name_space" followed by "__" followed by "name" convention,
but I am not sure if that is a desirable convention to spread
throughout our codebase.
Also "unix_stream_server" is quite a mouthful. Perhaps abbreviate
it to uss_ or something? I dunno if that is too short and invite
confusion with other kinds of uss.