Thread (3 messages) flat view 3 messages, 3 authors, 2021-02-19

Re: [PATCH 4/4] tests: remove most uses of test_i18ncmp

From: Junio C Hamano <hidden>
Date: 2021-02-11 19:23:35

Ævar Arnfjörð Bjarmason  [off-list ref] writes:
As a follow-up to d162b25f956 (tests: remove support for
GIT_TEST_GETTEXT_POISON, 2021-01-20) remove most uses of test_i18ncmp
via a simple s/test_i18ncmp/test_cmp/g search-replacement.
I am a bit hesitant to take this step, primarily because the
distinction between test_cmp and test_i18ncmp is serving as a sign
for tests to identify if they are dealing with translatable messages
or plumbing/machine-readable messages.

If a totally different approach to test i18n messging part
(e.g. Dscho's rot13) appears any time soon, it would be helpful to
leave these distinction in, rather than ripping them out, with two
caveats.

 - If such a change does happen soon enough, then the codebase this
   huge patch touches would not be all that different by the time
   when it happens, so reverting this patch should not be too
   involved, which means my hesitation is not all that warranted.

 - If such a change does not happen for some time, then it would
   become impractical to revert this patch when it does happen due
   to changes in the codebase, if we apply it with the intention of
   "we can easily revert if we need to".  But even if we drop this
   step, until such a change appears, we surely will gain more calls
   to test_cmp (and possibly test_i18ncmp) in the codebase, and at
   that point, we can trust the distinction between test_cmp and
   test_i18ncmp even less, which means it does not help all that
   much if we tried to keep test_i18ncmp.

So, perhaps we should bite the bullet and just take this step.

Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help