The problem is that original name I've used lies to the reader, or, more
precisely, tells half-truth. True meaning of the variable is "do run
diff for any commit, no matter if it's merge or not". So "need_diff" is
already better than "regulars_need_diff".
Maybe "diff_all_commits" will do?