Re: [PATCH v1 06/27] diff-merges: rename all functions to have common prefix
From: Sergey Organov <hidden>
Date: 2020-12-03 17:50:47
Junio C Hamano [off-list ref] writes:
Sergey Organov [off-list ref] writes:quoted
Use the same "diff_merges" prefix for all the diff merges function names. Signed-off-by: Sergey Organov <redacted> --- builtin/log.c | 4 ++-- diff-merges.c | 10 +++++----- diff-merges.h | 15 ++++++++++----- revision.c | 6 +++--- 4 files changed, 20 insertions(+), 15 deletions(-)diff --git a/builtin/log.c b/builtin/log.c index ad3092fdd854..77a7bba543ad 100644 --- a/builtin/log.c +++ b/builtin/log.c@@ -599,7 +599,7 @@ static int show_tree_object(const struct object_id *oid, static void show_setup_revisions_tweak(struct rev_info *rev, struct setup_revision_opt *opt) { - rev_diff_merges_default_to_dense_combined(rev); + diff_merges_default_to_dense_combined(rev); if (!rev->diffopt.output_format) rev->diffopt.output_format = DIFF_FORMAT_PATCH; }@@ -724,7 +724,7 @@ static void log_setup_revisions_tweak(struct rev_info *rev, if (!rev->diffopt.output_format && rev->combine_merges) rev->diffopt.output_format = DIFF_FORMAT_PATCH; - rev_diff_merges_first_parent_defaults_to_enable(rev); + diff_merges_first_parent_defaults_to_enable(rev);Even with a different prefix, this name does not make it clear what is going on to its readers. The other name is OK, though.
As this name goes away later, let's relax this one, and focus on the final name, OK? Thanks, -- Sergey Organov