Thread (1 message) 1 message, 1 author, 2020-11-04

Re: [PATCH] pack-write: use hashwrite_be32() instead of double-buffering array

From: Junio C Hamano <hidden>
Date: 2020-11-04 16:23:25

Jeff King [off-list ref] writes:
On Sun, Nov 01, 2020 at 09:52:12AM +0100, René Scharfe wrote:
quoted
hashwrite() already buffers writes, so pass the fanout table entries
individually via hashwrite_be32(), which also does the endianess
conversion for us.  This avoids a memory copy, shortens the code and
reduces the number of magic numbers.
Yep, this seems trivially correct. The key observation is that we are
filling the array in order:
quoted
@@ -101,20 +100,19 @@ const char *write_idx_file(const char *index_name, struct pack_idx_entry **objec
 	for (i = 0; i < 256; i++) {
 		struct pack_idx_entry **next = list;
 		while (next < last) {
 			struct pack_idx_entry *obj = *next;
 			if (obj->oid.hash[0] != i)
 				break;
 			next++;
 		}
-		array[i] = htonl(next - sorted_by_sha);
+		hashwrite_be32(f, next - sorted_by_sha);
 		list = next;
 	}
-	hashwrite(f, array, 256 * 4);
Perhaps obvious, but I got bit trying to do another similar conversion
recently that was filling in the array out-of-order...
Yeah, filling an array out of order and then writing the result in
order would obviously different from writing out individual pieces
in the order the original codeflow used to fill the array.  Worse,
the order the data items are fed to hashwrite() obviously affects
the hash computed at the end.  An example of too much abstraction
biting us? ;-)

Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help