On Thu, Aug 13, 2020 at 07:17:20PM +0200, René Scharfe wrote:
-- >8 --
Subject: [PATCH v2] fast-export: deduplicate anonymization handling
Move the code for converting an object_id to a hexadecimal string and
for handling of the default (not anonymizing) case from its callers to
anonymize_oid() and consequently rename it to anonymize_oid_if_needed().
This reduces code duplication.
I think this is a bad direction unless you're going to do it for all of
the other anonymize_*() functions, as well, for consistency. And there
it gets tricky because the caller is able to use the anonymizing
knowledge in more places.
I actually liked your original version better.
-Peff