Re: [PATCH 2/4] t7401: change test_i18ncmp syntax for clarity
From: Junio C Hamano <hidden>
Date: 2020-08-05 21:23:54
Shourya Shukla [off-list ref] writes:
Change the test_i18ncmp syntax from 'test_i18ncmp actual expected' to 'test_i18ncmp expected actual' to align it with the convention followed by other tests in the test script.
Yeah, this is a good thing to do, as a failing test_cmp gives a diff between the first file to the second file, i.e. a patch that turns the expected output into what the tests actually produced, so that the tester can see how the expectation is broken.
quoted hunk
Mentored-by: Christian Couder [off-list ref] Mentored-by: Kaartic Sivaraam [off-list ref] Signed-off-by: Shourya Shukla <redacted> --- t/t7401-submodule-summary.sh | 8 ++++---- 1 file changed, 4 insertions(+), 4 deletions(-)diff --git a/t/t7401-submodule-summary.sh b/t/t7401-submodule-summary.sh index 4439fb7c17..18fefdb0ba 100755 --- a/t/t7401-submodule-summary.sh +++ b/t/t7401-submodule-summary.sh@@ -183,7 +183,7 @@ test_expect_success 'typechanged submodule(submodule->blob), --cached' " < Add foo5 EOF - test_i18ncmp actual expected + test_i18ncmp expected actual " test_expect_success 'typechanged submodule(submodule->blob), --files' "@@ -193,7 +193,7 @@ test_expect_success 'typechanged submodule(submodule->blob), --files' " > Add foo5 EOF - test_i18ncmp actual expected + test_i18ncmp expected actual " rm -rf sm1 &&@@ -204,7 +204,7 @@ test_expect_success 'typechanged submodule(submodule->blob)' " * sm1 $head4(submodule)->$head5(blob): EOF - test_i18ncmp actual expected + test_i18ncmp expected actual " rm -f sm1 &&@@ -217,7 +217,7 @@ test_expect_success 'nonexistent commit' " Warn: sm1 doesn't contain commit $head4_full EOF - test_i18ncmp actual expected + test_i18ncmp expected actual " commit_file