Re: [PATCH] sparse-checkout: improve OS ls compatibility
From: Junio C Hamano <hidden>
Date: 2019-12-19 22:01:16
Ed Maste [off-list ref] writes:
quoted
Note that the helper function's name no longer reflects what it does with such a change, so it needs to be renamed. Together with style fix, perhaps ls_no_dot () { (cd "$1" && printf "%s\n *) } is what we want,I believe the tests should pass or be skipped when run as root, so I think we should either require (something like) SANITY for these tests, or make the change above. I'm happy with either option; I'll send a v2 based on the approach above for consideration.
OK, after thinking about it a bit more, I think "Your ls is broken" was completely missing the point. What we want in the callers of this helper is to list the contents of a directory, and "ls" is one possible (and easiest, if there were no "oops, sometimes -A is enabled implementation by default" complication) implementation. And "ls_no_dot" is a misnomer from that point of view. We are not even using "ls", so perhaps we should just call it "list_files" or something? Thanks.