Thread (1 message) 1 message, 1 author, 2019-12-16

Re: [Outreachy] [PATCH] bisect--helper: change `retval` to `res`

From: Junio C Hamano <hidden>
Date: 2019-12-16 19:09:02

Miriam Rubio [off-list ref] writes:
From: Tanushree Tumane <redacted>

Convert of variable `retval` to `res` make `bisect--helper.c` 
more consistent.

Now, 110 ocurrences of `res` in file and zero `retval` occurrences.
And why is this a desirable change, not merely a distracting code
churn?

IOW, are there other changes that build on this change that benefits
from the fact that the variable that holds the value to be returned
is always called "res" after this patch gets applied?

FWIW, I actually think "retval" would be a more appropriate name for
the variable that holds the value to be returned than "res", but it
is not worth the churn either way---I see this more as "once the
code is written one way, it is not worth wasting bits and brain
cycles to change it" kind of issue.

Unless there are other valid reasons to do this change, that is.

Thanks.
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help