Thread (3 messages) 3 messages, 3 authors, 2019-12-04

Re: [PATCH] send-pack: use OBJECT_INFO_QUICK to check negative objects

From: Jeff King <hidden>
Date: 2019-12-03 23:20:09

On Sat, Nov 30, 2019 at 09:08:32AM -0800, Junio C Hamano wrote:
quoted
Interestingly, upload-pack does not use OBJECT_INFO_QUICK when it's
getting oids from the other side. But I think it could possibly benefit
in the same way. Nobody seems to have noticed. Perhaps it simply comes
up less, as servers would tend to have more objects than their clients?
Makes me wonder how many times we wre bitten by the fact that
INFO_SKIP_FETCH_OBJECT does not imply INFO_QUICK.  Perhaps most of
the users of INFO_SKIP_FETCH_OBJECT wants to use INFO_FOR_PREFETCH?
We seem to be discussing this about once a month lately. :)

There's some good digging by Jonathan in:

  https://public-inbox.org/git/20191011220822.154063-1-jonathantanmy@google.com/

That thread is also about this exact same spot, which is why I cc'd him
originally.

I do tend to think that QUICK ought to imply SKIP_FETCH. I'm slightly
negative on sprinkling FOR_PREFETCH everywhere, because the name implies
to me that we are telling object_info() that we are pre-fetching. Which
yes, has the effect we want, but I think is misleading. So we'd want to
change the name of the combined flag, I think, or just let QUICK imply
SKIP_FETCH and use that more thoroughly.

-Peff
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help