Jeff King [off-list ref] writes:
Yeah, I think one path forward could be:
- add path_exists(); this will work the same as file_exists(), but is
a better name. Keep file_exists() for now, but put a comment that
new calls should use path_exists().
- use path_exists() in builtin/clone.c, ditching its custom
dir_exists()
Both are of immediate value ;-)
- (optional) start converting file_exists() calls to path_exists(),
after confirming what each call wants (just files, or any path)
That is of lessor urgency but the result has a good documentation
value.