Re: sizeof(var) vs sizeof(type), was Re: [PATCH] git: use COPY_ARRAY and MOVE_ARRAY in handle_alias()
From: Derrick Stolee <hidden>
Date: 2019-09-26 16:16:21
From: Derrick Stolee <hidden>
Date: 2019-09-26 16:16:21
On 9/26/2019 11:24 AM, Philip Oakley wrote:
On 26/09/2019 14:36, Derrick Stolee wrote:quoted
quoted
quoted
Another good reason to use "sizeof(var)" instead of sizeof(type)". :)That is indeed a very good reason, in addition to getting the type right automatically (by virtue of letting the compiler pick it). Should we make this an explicit guideline in our documentation?Better yet: can we create a Coccinelle script to fix it automatically? -StoleeHow about 'Both'. We can't assume all contributors have Coccinelle on their OS/system.
Both is best, but I find static checkers to be more reliable than updating documentation. For that reason, I would prioritize the Coccinelle script over adding another bullet point to the style guide. The PR builds for GitGitGadget run ci/run-static-analysis.sh as a check (see the StaticAnalysis job in [1] for an example). That provides a free way to get feedback for users without Coccinelle. [1] https://dev.azure.com/gitgitgadget/git/_build/results?buildId=16864&view=logs Thanks, -Stolee