"brian m. carlson" [off-list ref] writes:
Well, I split it out from a function that handles multiple path
components, mostly so that I could leverage existing work (and not have
to worry about getting it wrong). It wasn't explicitly intended that it
support multiple components, since I don't require that for my
implementation, but I could see future users taking advantage of that.
I think "ends_with_path_components" might be the way forward, unless
you think something else would be better.
Good; thanks.