Elijah Newren [off-list ref] writes:
+static int parse_opt_reencode_mode(const struct option *opt,
+ const char *arg, int unset)
+{
+ if (unset || !strcmp(arg, "abort"))
+ reencode_mode = REENCODE_ABORT;
+ else if (!strcmp(arg, "yes") || !strcmp(arg, "true") || !strcmp(arg, "on"))
+ reencode_mode = REENCODE_YES;
+ else if (!strcmp(arg, "no") || !strcmp(arg, "false") || !strcmp(arg, "off"))
+ reencode_mode = REENCODE_NO;
Don't duplicate the logic; find existing callers of git_parse_maybe_bool(),
learn what they are using the helper for and mimic them, perhaps?