Re: [PATCH v9 00/21] Convert "git stash" to C builtin
From: Junio C Hamano <hidden>
Date: 2018-09-26 18:37:15
Paul-Sebastian Ungureanu [off-list ref] writes:
Hello, This is a new iteration of `git stash`, based on the last review I got. This new iteration brings mostly code styling fix issues in order to make the code more readable. There is also a new patch "strbuf.c: add `strbuf_join_argv()`". By making some small changes, the code is now a little bit closer to be used as API. Joel Teichroeb (5): stash: improve option parsing test coverage stash: convert apply to builtin stash: convert drop and clear to builtin stash: convert branch to builtin stash: convert pop to builtin Paul-Sebastian Ungureanu (16): sha1-name.c: add `get_oidf()` which acts like `get_oid()` strbuf.c: add `strbuf_join_argv()` stash: update test cases conform to coding guidelines stash: rename test cases to be more descriptive stash: add tests for `git stash show` config stash: convert list to builtin stash: convert show to builtin stash: mention options in `show` synopsis. stash: convert store to builtin stash: convert create to builtin stash: convert push to builtin stash: make push -q quiet stash: convert save to builtin stash: convert `stash--helper.c` into `stash.c` stash: optimize `get_untracked_files()` and `check_changes()` stash: replace all `write-tree` child processes with API calls
Here is how these appear in my MUA. I am guessing that 03/21 is the
right copy and 02/21 that appear after 21/21 is a duplicat that I
should not even look at (the same for 4 other ones with [GSoC]
label)?
[ 53: PSU] [PATCH v9 00/21] Convert "git stash" to C builtin
[ 57: PSU] [PATCH v9 01/21] sha1-name.c: add `get_oidf()` which acts like `get_oid()`
[ 56: PSU] [PATCH v9 02/21] strbuf.c: add `strbuf_join_argv()`
[ 68: PSU] [PATCH v9 03/21] stash: improve option parsing test coverage
[ 378: PSU] [PATCH v9 04/21] stash: update test cases conform to coding guidelines
[ 78: PSU] [PATCH v9 05/21] stash: rename test cases to be more descriptive
[ 102: PSU] [PATCH v9 06/21] stash: add tests for `git stash show` config
[ 632: PSU] [PATCH v9 07/21] stash: convert apply to builtin
[ 199: PSU] [PATCH v9 08/21] stash: convert drop and clear to builtin
[ 132: PSU] [PATCH v9 09/21] stash: convert branch to builtin
[ 151: PSU] [PATCH v9 10/21] stash: convert pop to builtin
[ 100: PSU] [PATCH v9 11/21] stash: convert list to builtin
[ 296: PSU] [PATCH v9 12/21] stash: convert show to builtin
[ 56: PSU] [PATCH v9 13/21] stash: mention options in `show` synopsis.
[ 165: PSU] [PATCH v9 14/21] stash: convert store to builtin
[ 513: PSU] [PATCH v9 15/21] stash: convert create to builtin
[ 339: PSU] [PATCH v9 16/21] stash: convert push to builtin
[ 195: PSU] [PATCH v9 17/21] stash: make push -q quiet
[ 430: PSU] [PATCH v9 18/21] stash: convert save to builtin
[ 575: PSU] [PATCH v9 19/21] stash: convert `stash--helper.c` into `stash.c`
[ 156: PSU] [PATCH v9 20/21] stash: optimize `get_untracked_files()` and `check_changes()`
[ 130: PSU] [PATCH v9 21/21] stash: replace all `write-tree` child processes with API calls
[ 68: PSU] [GSoC][PATCH v9 02/21] stash: improve option parsing test coverage
[ 378: PSU] [GSoC][PATCH v9 03/21] stash: update test cases conform to coding guidelines
[ 78: PSU] [GSoC][PATCH v9 04/21] stash: rename test cases to be more descriptive
[ 102: PSU] [GSoC][PATCH v9 05/21] stash: add tests for `git stash show` config
[ 55: PSU] [GSoC][PATCH v9 06/21] strbuf.c: add `strbuf_join_argv()`
Thanks.
Documentation/git-stash.txt | 4 +- Makefile | 2 +- builtin.h | 1 + builtin/stash.c | 1595 ++++++++++++++++++++++++++++++++++ cache.h | 1 + git-stash.sh | 752 ---------------- git.c | 1 + sha1-name.c | 19 + strbuf.c | 15 + strbuf.h | 7 + t/t3903-stash.sh | 192 ++-- t/t3907-stash-show-config.sh | 83 ++ 12 files changed, 1851 insertions(+), 821 deletions(-) create mode 100644 builtin/stash.c delete mode 100755 git-stash.sh create mode 100755 t/t3907-stash-show-config.sh