Re: [PATCH 3/3] transport.c: introduce core.alternateRefsPrefixes
From: Junio C Hamano <hidden>
Date: 2018-09-21 16:40:07
Eric Sunshine [off-list ref] writes:
On Thu, Sep 20, 2018 at 2:04 PM Taylor Blau [off-list ref] wrote:quoted
The recently-introduced "core.alternateRefsCommand" allows callers to specify with high flexibility the tips that they wish to advertise from alternates. This flexibility comes at the cost of some inconvenience when the caller only wishes to limit the advertisement to one or more prefixes. [...] Signed-off-by: Taylor Blau <redacted> ---diff --git a/t/t5410-receive-pack.sh b/t/t5410-receive-pack.sh@@ -44,4 +44,15 @@ test_expect_success 'with core.alternateRefsCommand' ' +test_expect_success 'with core.alternateRefsPrefixes' ' + test_config -C fork core.alternateRefsPrefixes "refs/tags" && + cat >expect <<-EOF && + $(git rev-parse one) .have + $(git rev-parse three) .have + $(git rev-parse two) .have + EOFIt's probably a matter of taste as to which is more readable, but this entire "cat <<EOF" block could be replaced with a simple one-liner: printf "%s .have\n" $(git rev-parse one three two) >expect && Same comment applies to previous patch, as well.
If the expected pattern is expected to stay to be just a sequence of "<oid> .have" and nothing else for the foreseeable future, I think it is a good idea.
quoted
+ printf "0000" | git receive-pack fork | extract_haves >actual && + test_cmp expect actual +'