Duy Nguyen [off-list ref] writes:
In the end, there's no variant, only one function that always takes
'struct repository *' and I wanted to keep the shorter name 'rerere'.
But let's go with adding repo_rerere() and deprecating rerere(). If it
turns out later that repo_rerere is too long (or it's repo_xyz
everywhere) then we can do another rename.
Yup, I am not opposed to another rename after the dust settles, but
do nto want to see it as part of the series.
Thanks.