On Fri, Aug 10, 2018 at 04:27:25PM -0700, Stefan Beller wrote:
quoted
cache.h | 13 ++++++++++++-
packfile.h | 8 ++------
2 files changed, 14 insertions(+), 7 deletions(-)
rubs me the wrong way. ;-)
cache.h is such a misnomer of a name, and a kitchen sink
of a file in the Git project that in an ideal world it would
be way smaller and contain only things related to some
caching related code.
I would suggest object.h or object-store.h instead.
Probably the object-store as that will be the only external
exposure and hopefully we'd get the objects in a similar
shape as the refs subsystem eventually?
Yes, for_each_loose_object() ought to be in loose.h to match packfile.h,
or the whole thing should go into object-store.h.
This series was already getting long, though, so I'd much rather do this
now and other reorganization later (in particular, wherever they end up,
we want the flags to move as a unit).
-Peff