Thread (26 messages) flat view 26 messages, 5 authors, 2018-08-06

Re: [RFC PATCH 3/5] pack-objects: add delta-islands support

From: Christian Couder <hidden>
Date: 2018-08-05 17:28:09

On Sun, Jul 22, 2018 at 10:55 AM, Duy Nguyen [off-list ref] wrote:
On Sun, Jul 22, 2018 at 7:52 AM Christian Couder
[off-list ref] wrote:
quoted
-       /*
-        * And then all remaining commits and tags.
-        */
-       for (i = last_untagged; i < to_pack.nr_objects; i++) {
-               if (oe_type(&objects[i]) != OBJ_COMMIT &&
-                   oe_type(&objects[i]) != OBJ_TAG)
-                       continue;
-               add_to_write_order(wo, &wo_end, &objects[i]);
-       }
+               /*
+                * Then fill all the tagged tips.
+                */
If we move the code in this loop to a separate function, in a separate
patch, first, would it produce a better diff? I think all the
indentation change here makes it a bit hard to read.
Sorry I just realized that I forgot to try to do that. It will be on
my todo list for the next iteration.

Thanks,
Christian.
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help