Thread (16 messages) 16 messages, 5 authors, 2018-11-01

Re: [PATCH v4 9/9] Documentation/config: add odb.<name>.promisorRemote

From: Stefan Beller <hidden>
Date: 2018-08-02 22:56:10

On Wed, Aug 1, 2018 at 11:16 PM Christian Couder
[off-list ref] wrote:
quoted hunk ↗ jump to hunk
From: Christian Couder <redacted>

Signed-off-by: Junio C Hamano <redacted>
---
 Documentation/config.txt | 5 +++++
 1 file changed, 5 insertions(+)
diff --git a/Documentation/config.txt b/Documentation/config.txt
index 43b2de7b5f..2d048d47f2 100644
--- a/Documentation/config.txt
+++ b/Documentation/config.txt
@@ -2513,6 +2513,11 @@ This setting can be overridden with the `GIT_NOTES_REWRITE_REF`
 environment variable, which must be a colon separated list of refs or
 globs.

+odb.<name>.promisorRemote::
+       The name of a promisor remote. For now promisor remotes are
+       the only kind of remote object database (odb) that is
+       supported.
+
Can you explain the end goal for this? (I did not find it in the cover letter,
nor do I make sense of this documentation)

So from what I understand, this series relates to partialClone, which
has the remote name of the "promisor" in extensions.partialclone.
That is the remote to contact for any needs w.r.t. partial clone and
fetching on demand.

This key "odb.<name1>.promisorRemote = <name2>" introduces
2 new names, where do each of these two names hook in?
name2 is a remote, such as "origin" from what I can tell, but
which naming scheme does name1 follow here?

What makes the odb key different, in that the partial clone
feature only handles objects as well?
 pack.window::
        The size of the window used by linkgit:git-pack-objects[1] when no
        window size is given on the command line. Defaults to 10.
--
2.18.0.330.g17eb9fed90
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help