Ramsay Jones [off-list ref] writes:
quoted
OPT_BOOL( 0 , "ignore-missing", &ignore_missing, N_("check if - even missing - files are ignored in dry run")),
- OPT_STRING( 0 , "chmod", &chmod_arg, N_("(+/-)x"), N_("override the executable bit of the listed files")),
+ { OPTION_STRING, 0, "chmod", &chmod_arg, "(+|-)x",
Am I alone in thinking that "(+x|-x)" is more readable?
I think I am guilty of that, and I agree yours is much easier to
read.
It can of course come on top of the series.