Duy Nguyen [off-list ref] writes:
And we could even do something like this to make custom builds
easier. Some more gluing is needed so you can set this from config.mak
but you get the idea. This removes all limits set by this
series.
Yes, we _could_, but it would mean we would have many variants of
the codepath that is pretty crucial to the integrity of the data we
keep in the repository, all of which must pretty much be bug-free.
Readability in pack-objects.c and object_entry struct declaration
is still a concern though.
Yup, a change like this does not change the readability; personally,
I do not think the original is _too_ bad, though.