Derrick Stolee [off-list ref] writes:
quoted
I do not think they are wrong, but aren't the latter two somewhat
redundant? "num" is p->num_objects, and we call (first+1)th element
only after we see (first < num - 1), i.e. first+1 < num, and the
access to (first-1)th is done only when first > 0. The first one,
i.e. when first points at where we _would_ find it if it existed,
can access "first" that could be p->num_objects, so the change there
makes sense, though.
Yes. But I'd rather keep the blocks consistent and use the return
value of nth_packed_object_oid() when possible.
Sure, I do not think anybody minds; I just wanted a sanity check.
Thansk.