Re: [PATCH v2 10/14] commit-graph: add core.commitgraph setting
From: Igor Djordjevic <hidden>
Date: 2018-01-31 22:44:38
Hi Derrick, On 30/01/2018 22:39, Derrick Stolee wrote:
quoted hunk ↗ jump to hunk
diff --git a/Documentation/config.txt b/Documentation/config.txt index 0e25b2c92b..5b63559a2b 100644 --- a/Documentation/config.txt +++ b/Documentation/config.txt@@ -898,6 +898,9 @@ core.notesRef:: This setting defaults to "refs/notes/commits", and it can be overridden by the `GIT_NOTES_REF` environment variable. See linkgit:git-notes[1]. +core.commitgraph::
^^^ A small style nitpick - you may want to use "core.commitGraph" throughout the series (note capital "G"), making it more readable and aligning with the rest of `git config` variable names (using "bumpyCaps" as per coding guidelines[1], and as seen a few lines below, at the end of this very patch, too, "core.sparseCheckout").
quoted hunk ↗ jump to hunk
+ Enable git commit graph feature. Allows reading from .graph files. + core.sparseCheckout:: Enable "sparse checkout" feature. See section "Sparse checkout" in linkgit:git-read-tree[1] for more information.diff --git a/cache.h b/cache.h index d8b975a571..e50e447a4f 100644 --- a/cache.h +++ b/cache.h@@ -825,6 +825,7 @@ extern char *git_replace_ref_base; extern int fsync_object_files; extern int core_preload_index; extern int core_apply_sparse_checkout; +extern int core_commitgraph;
^^^ Similar nit here, might be "core_commit_graph" (throughout the series) would align better with existing variable names around it (note additional underscore between "commit" and "graph"), but also with your own naming "scheme" used for cmd_commit_graph(), builtin_commit_graph_usage[], construct_commit_graph(), etc.
quoted hunk ↗ jump to hunk
extern int precomposed_unicode; extern int protect_hfs; extern int protect_ntfs;diff --git a/config.c b/config.c index e617c2018d..99153fcfdb 100644 --- a/config.c +++ b/config.c@@ -1223,6 +1223,11 @@ static int git_default_core_config(const char *var, const char *value) return 0; } + if (!strcmp(var, "core.commitgraph")) { + core_commitgraph = git_config_bool(var, value); + return 0; + } + if (!strcmp(var, "core.sparsecheckout")) { core_apply_sparse_checkout = git_config_bool(var, value); return 0;diff --git a/environment.c b/environment.c index 63ac38a46f..faa4323cc5 100644 --- a/environment.c +++ b/environment.c@@ -61,6 +61,7 @@ enum object_creation_mode object_creation_mode = OBJECT_CREATION_MODE; char *notes_ref_name; int grafts_replace_parents = 1; int core_apply_sparse_checkout; +int core_commitgraph; int merge_log_config = -1; int precomposed_unicode = -1; /* see probe_utf8_pathname_composition() */ unsigned long pack_size_limit_cfg;
Thanks, Buga [1] https://github.com/git/git/blob/master/Documentation/CodingGuidelines Externally Visible Names ... The section and variable names that consist of multiple words are formed by concatenating the words without punctuations (e.g. `-`), and are broken using bumpyCaps in documentation as a hint to the reader.