PAYRE NATHAN p1508475 [off-list ref] writes:
quoted
quoted
+sub parse_header_line {
+ my $lines = shift;
+ my $parsed_line = shift;
+ my $pattern = join "|", qw(To Cc Bcc);
Nit: you may want to rename it to something more explicit, like
$addr_headers_pat.
I find "$addr_headers_pat" too long that's why I've choose rename it
into "$addr_pat", in addition to that, because the variable is in the
subroutine "parse_header_line" it does not require to include
"headers" in the variable name.
I suggested this name because $addr_pat seems to imply that this matches
an address, while it matches the _name of headers_ containing address.
But that's not terribly important, the meaning is clear by the context
anyway.
All my previous remarks have been taken into account. This is now
Reviewed-by: Matthieu Moy <redacted>
Thanks,
--
Matthieu Moy
https://matthieu-moy.fr/