On Sun, Oct 29, 2017 at 03:02:20PM -0400, Eric Sunshine wrote:
On Sun, Oct 29, 2017 at 1:57 PM, brian m. carlson
[off-list ref] wrote:
quoted
I can do CURRENT_HASH_ALGO or CURRENT_HASH instead if you think that's
an improvement. I originally omitted the "algo" portion to keep it
short.
I don't have strong feelings about it aside from worrying about a
"current_hash" name clash or a reader misunderstanding what it
represents.
Does "current" need to be in the name? What about HASH_ALGO or REPO_HASH_ALGO?
quoted
Alternatively, we could have a current_hash() (or current_hash_algo())
inline function if people like that better.
hash_algo() or repo_hash_algo()?
Those are also fine, and shorter to boot. I'll wait to see if anyone
has strong opinions on the direction we should go before making a
change.
--
brian m. carlson / brian with sandals: Houston, Texas, US
https://www.crustytoothpaste.net/~bmc | My opinion only
OpenPGP: https://keybase.io/bk2204