On Mon, 2017-10-23 at 12:44 -0700, Stefan Beller wrote:
+static void get_error_msg(struct strbuf* error_msg, const char* oldname, unsigned old_branch_exists,
quoted
+ const char* newname, int new_branch_validation_result)
nit here and in the return of validate_branch_creation:
It would be clearer if this is not just 'int', but actually spelling
out that it is the enum.
Thanks. That's a good suggestion. I'll fix it while dropping [PATCH
3/5] that cleans up the 'validate_new_branchname' function as there's
already another series that refactored the same function and got merged
to 'next',
https://public-inbox.org/git/20171013051132.3973-1-gitster@pobox.com/
--
Kaartic