Jonathan Nieder [off-list ref] writes:
The git_connect function is growing long. Split the portion that
discovers an ssh command and options it accepts before the service
name and path to a separate function to make it easier to read.
No functional change intended.
Signed-off-by: Jonathan Nieder <redacted>
Reviewed-by: Stefan Beller <redacted>
---
As before, except for the Reviewed-by.
connect.c | 116 +++++++++++++++++++++++++++++++++-----------------------------
1 file changed, 61 insertions(+), 55 deletions(-)
Looks like a straight-forwrd split. Makes sense.
Thanks.