Thread (1 message) 1 message, 1 author, 2017-07-29

Re: [RFC PATCH 1/4] environment, fsck: introduce lazyobject extension

From: Junio C Hamano <hidden>
Date: 2017-07-29 00:21:18

Jonathan Tan [off-list ref] writes:
quoted
quoted
 extern int repository_format_precious_objects;
+extern char *repository_format_lazy_object;
This is not a new problem, but I think these two should be
called repository_extension_$NAME not repository_format_$NAME.
Looking at the original commit 067fbd4 ("introduce "preciousObjects"
repository extension", 2015-06-24), it seems that this was so named to
be analogous to the existing "struct repository_format { int version;
...}" => "int repository_format_version;". The existing
repository_format_$NAME thus seems reasonable to me.
OK.  They smell like "repository extension" to me, but probably the
fully spelled name of the concept is "repository format extension",
so using the word "format" out of that phrase sounds OK to me.

Thanks.
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help