Re: [PATCHv4 00/17] Diff machine: highlight moved lines.
From: Stefan Beller <hidden>
Date: 2017-05-30 21:38:26
On Fri, May 26, 2017 at 6:04 PM, Jacob Keller [off-list ref] wrote:
On Mon, May 22, 2017 at 7:40 PM, Stefan Beller [off-list ref] wrote:quoted
v4: * interdiff to v3 (what is currently origin/sb/diff-color-move) below. * renamed the "buffered_patch_line" to "diff_line". Originally I planned to not carry the "line" part as it can be a piece of a line as well. But for the intended functionality it is best to keep the name. If we'd want to add more functionality to say have a move detection for words as well, we'd rename the struct to have a better name then. For now diff_line is the best. (Thanks Jonathan Nieder!) * tests to demonstrate it doesn't mess with --color-words as well as submodules. (Thanks Jonathan Tan!) * added in the statics (Thanks Ramsay!) * smaller scope for the hashmaps (Thanks Jonathan Tan!) * some commit messages were updated, prior patch 4-7 is squashed into one (Thanks Jonathan Tan!) * the tests added revealed an actual fault: now that the submodule process is not attached to a dupe of our stdout, it would stop coloring the output. We need to pass on use-color explicitly. * updated the NEEDSWORK comment in the second last patch. Thanks for bearing, StefanOne thing to note when I was playing around with what's on pu right now, I noticed that the oldMovedAlternative and newMovedAlternative are the first moved colors to be used if there is only one move. (Ie: a simple case of literally one section moved) This is a bit weird that the alternative colors are used before the "main" colors. I would have thought it would be the other way.
While pu is not up-to-date, I double checked with the most recent implementation and that is no longer the case.
I noticed this because the default colors do not work well for my terminal color scheme and I had to configure but realized that I needed to configure the alternative ones to make a difference in the simple diff I was viewing.
The v4 that you tested, is the "alternate" scheme in the resend https://public-inbox.org/git/20170527001820.25214-2-sbeller@google.com/ Thanks, Stefan