Rename 'free_submodules_sha1s()' to 'free_submodules_oids()' since the
function frees a 'struct string_list' which has a 'struct oid_array'
stored in the 'util' field.
Change-Id: I0c52fa3af1b1492b196bcf52f8b8cc8f5daf085d
Signed-off-by: Brandon Williams <redacted>
---
submodule.c | 5 +++--
1 file changed, 3 insertions(+), 2 deletions(-)
diff --git a/submodule.c b/submodule.c
index be0f5d847..46abd52b1 100644
--- a/submodule.c
+++ b/submodule.c
@@ -738,7 +738,7 @@ static void find_unpushed_submodule_commits(struct commit *commit,
diff_tree_combined_merge(commit, 1, &rev);
}
-static void free_submodules_sha1s(struct string_list *submodules)
+static void free_submodules_oids(struct string_list *submodules)
{
struct string_list_item *item;
for_each_string_list_item(item, submodules)@@ -779,7 +779,8 @@ int find_unpushed_submodules(struct oid_array *commits,
if (submodule_needs_pushing(submodule->string, commits))
string_list_insert(needs_pushing, submodule->string);
}
- free_submodules_sha1s(&submodules);
+
+ free_submodules_oids(&submodules);
return needs_pushing->nr;
}
--
2.13.0.rc1.294.g07d810a77f-goog