Re: [PATCH v2 00/21] object_id part 7
From: Junio C Hamano <hidden>
Date: 2017-03-28 17:32:49
Jeff King [off-list ref] writes:
On Sun, Mar 26, 2017 at 04:01:22PM +0000, brian m. carlson wrote:quoted
This is part 7 in the continuing transition to use struct object_id. This series focuses on two main areas: adding two constants for the maximum hash size we'll be using (which will be suitable for allocating memory) and converting struct sha1_array to struct oid_array.Both changes are very welcome. I do think it's probably worth changing the name of sha1-array.[ch], but it doesn't need to happen immediately. I read through the whole series and didn't find anything objectionable. The pointer-arithmetic fix should perhaps graduate separately.
I didn't see anything incorrect when I queued the series, either, and after I re-read it I saw a few minor readability issues, but modulo that this looks ready. I did split the push-cert parsing fix and applied to an older base independently, though.
I suggested an additional cleanup around "linelen" in one patch. In the name of keeping the number of re-rolls sane, I'm OK if we skip that for now (the only reason I mentioned it at all is that you have to justify the caveat in the commit message; with the fix, that justification can go away).
A follow-up after the dust settles could also mention "we earlier mentioned this caveat but with this fix we no longer have to worry about it", no? Thanks both, anyways.