Thread (4 messages) flat view 4 messages, 3 authors, 2017-02-28

Re: [BUG] branch renamed to 'HEAD'

From: Junio C Hamano <hidden>
Date: 2017-02-27 22:31:24

Jeff King [off-list ref] writes:
I guess something like the patch below works, but I wonder if there is a
less-horrible way to accomplish the same thing.
I suspect that a less-horrible would be a lot more intrusive.  It
would go like "interpret-branch-name only gives local branch name,
and when it does not show it, the callers that know they do not
necessarily need local branch name would call other at-mark things".
As you pointed out with the @{upstream} that potentially point at a
local branch, it will quickly get more involved, I would think, and
I tend to think that this patch of yours is probably the least evil
one among possible solutions.  

Perhaps with s/not_in_refs_heads/not_a_branch_name/ (or swapping
polarity, "is_a_branch_name"), the resulting code may not be too
hard to read?

Thanks.
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help