[PATCH 2/6 v5] revision.c: swap if/else blocks
From: Siddharth Kannan <hidden>
Date: 2017-02-25 07:31:14
Subsystem:
the rest · Maintainer:
Linus Torvalds
From: Siddharth Kannan <hidden>
Date: 2017-02-25 07:31:14
Subsystem:
the rest · Maintainer:
Linus Torvalds
Swap the condition and bodies of an "if (A) do_A else do_B" in setup_revisions() to "if (!A) do_B else do A", to make the change in the the next step easier to read. No behaviour change is intended in this step. Signed-off-by: Siddharth Kannan <redacted> --- revision.c | 6 +++--- 1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/revision.c b/revision.c
index 5674a9a..8d4ddae 100644
--- a/revision.c
+++ b/revision.c@@ -2238,7 +2238,9 @@ int setup_revisions(int argc, const char **argv, struct rev_info *revs, struct s } - if (handle_revision_arg(arg, revs, flags, revarg_opt)) { + if (!handle_revision_arg(arg, revs, flags, revarg_opt)) + got_rev_arg = 1; + else { int j; if (seen_dashdash || *arg == '^') die("bad revision '%s'", arg);
@@ -2255,8 +2257,6 @@ int setup_revisions(int argc, const char **argv, struct rev_info *revs, struct s append_prune_data(&prune_data, argv + i); break; } - else - got_rev_arg = 1; } if (prune_data.nr) {
--
2.1.4