Duy Nguyen [off-list ref] writes:
On Mon, Jan 9, 2017 at 12:30 PM, Jeff King [off-list ref] wrote:
quoted
I also wonder if it is worth just using argv_array. We do not care about
...
It is not much shorter than ALLOC_GROW(), but IMHO it is easier to read.
Indeed. My only complaint is it's "argv_array_" and not
"string_array_" but we could think about renaming it later when we see
another use like this.
Yup, when Peff said "argv-array", it took me a few breaths, until I
realized that argv-array was merely an array of strings, to convince
myself that the data structure can be used here. If we are going to
use it in more places, we may want to rename it somehow.