Re: [PATCH v2 0/6] shallow.c improvements
From: Jeff King <hidden>
Date: 2016-12-06 13:42:19
On Tue, Dec 06, 2016 at 07:53:33PM +0700, Nguyễn Thái Ngọc Duy wrote:
Nguyễn Thái Ngọc Duy (4): shallow.c: rename fields in paint_info to better express their purposes shallow.c: stop abusing COMMIT_SLAB_SIZE for paint_info's memory pools shallow.c: make paint_alloc slightly more robust shallow.c: remove useless code Rasmus Villemoes (2): shallow.c: avoid theoretical pointer wrap-around shallow.c: bit manipulation tweaks
The first 5 patches look obviously good to me. The naming changes in paint_alloc() make things much clearer, and the fixes retained from Rasmus are all obvious improvements. The final one _seems_ reasonable after reading your explanation, but I lack enough context to know whether or not there might be a corner case that you're missing. I'm inclined to trust your assessment on it. -Peff