Thread (4 messages) flat view 4 messages, 4 authors, 2016-08-11

Re: [PATCH/RFC] "init-db" can really be just "init"

From: Junio C Hamano <hidden>
Date: 2016-08-11 20:37:28

Nicolas Pitre [off-list ref] writes:
This should make first GIT impression a little less intimidating.

Signed-off-by: Nicolas Pitre <redacted>
I was not sure about this for quite some time, thinking that it
might make sense to default the behaviour of init-db for bare
repositories and give init as a user-level wrapper to drive
init-db to add customization suitable for repositories with
working trees.  List?
Maybe that could be a good rule of thumb to have all porcelainish 
commands not have any hyphen in their name, like "diff", "commit", 
"add", etc. ?
I was also hoping that would become the case except verify-tag,
cherry-pick, and format-patch.  Also I was wondering if it would
make sense to give two dashes to the back-end ones that never
get invoked by the end users directly (e.g. merge--recursive,
upload--pack) but thought it was too ugly.
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help