On Mon, 30 Oct 2006, Junio C Hamano wrote:
Johannes Schindelin [off-list ref] writes:
quoted
It is trivial to do now,...
May be, but can we do something about these duplicated code?
quoted
@@ -57,6 +60,40 @@ static ssize_t send_client_data(int fd,
return safe_write(fd, data, sz);
}
+FILE *pack_pipe = NULL;
+static void show_commit(struct commit *commit)
[...]
Yes, we could make mark_edges_uninteresting() and traverse_commit_list()
take a FILE * parameter, which is then passed to the functions. Hmmm?
Except show_commit() should not show "commit " in front of each line. So,
another parameter?
Ciao,
Dscho